<!doctype html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html class="no-js lt-ie9 lt-ie8" lang="en"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html class="no-js lt-ie9" lang="en"><![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en"><!--<![endif]-->
<head>
<meta charset="utf-8">
<meta name="author" content="Ognjen Regoje">

<title>Generating more interesting image previews using imagemagick &#8211; ognjen.io</title>

<meta name="description" content="Generating more interesting image previews using imagemagick by Ognjen Regoje">

<meta name="keywords" content="">
<!-- Twitter Cards -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://ognjen.io/images/image-previews.png">

<meta name="twitter:title" content="Generating more interesting image previews using imagemagick">
<meta name="twitter:description" content="A couple of tries at generating more interesting image previews using imagemagick with the mini_magick gem.">
<meta name="twitter:creator" content="@ognjenio">

<!-- Open Graph -->
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Generating more interesting image previews using imagemagick">
<meta property="og:description" content="A couple of tries at generating more interesting image previews using imagemagick with the mini_magick gem.">
<meta property="og:url" content="https://ognjen.io/generating-more-interesting-image-previews-using-imagemagick/">
<meta property="og:site_name" content="ognjen.io">

<meta property="og:image" name="/image" content="https://ognjen.io/images/image-previews.png">






<link href="https://fonts.googleapis.com/css?family=Lato&display=swap" rel="stylesheet">
<link rel="canonical" href="https://ognjen.io/generating-more-interesting-image-previews-using-imagemagick/">
<link href="https://ognjen.io/feed.xml" type="application/atom+xml" rel="alternate" title="ognjen.io Feed">


<!-- http://t.co/dKP3o1e -->
<meta name="HandheldFriendly" content="True">
<meta name="MobileOptimized" content="320">
<meta name="viewport" content="width=device-width, initial-scale=1.0">

<!-- Google Webfonts -->
<link href='https://fonts.googleapis.com/css?family=PT+Sans+Narrow:400,700|PT+Serif:400,700,400italic' rel='stylesheet' type='text/css'>
<!-- For all browsers -->
<link rel="stylesheet" href="/assets/css/main.css">

<meta http-equiv="cleartype" content="on">

<!-- HTML5 Shiv and Media Query Support -->
<!--[if lt IE 9]>
	<script src="https://ognjen.io/assets/js/vendor/html5shiv.min.js"></script>
	<script src="https://ognjen.io/assets/js/vendor/respond.min.js"></script>
<![endif]-->

<!-- Modernizr -->
<script src="https://ognjen.io/assets/js/vendor/modernizr-2.7.1.custom.min.js"></script>

<!-- Icons -->
<!-- 16x16 -->
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/images/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/images/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/images/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/images/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="/images/apple-touch-icon-60x60.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/apple-touch-icon-152x152.png" />
<link rel="icon" type="/image/png" href="/images/favicon-196x196.png" sizes="196x196" />
<link rel="icon" type="/image/png" href="/images/favicon-96x96.png" sizes="96x96" />
<link rel="icon" type="/image/png" href="/images/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="/image/png" href="/images/favicon-16x16.png" sizes="16x16" />
<link rel="icon" type="/image/png" href="/images/favicon-128.png" sizes="128x128" />
<meta name="application-name" content="&nbsp;"/>
<meta name="msapplication-TileColor" content="#FFFFFF" />
<meta name="msapplication-TileImage" content="/images/mstile-144x144.png" />
<meta name="msapplication-square70x70logo" content="/images/mstile-70x70.png" />
<meta name="msapplication-square150x150logo" content="/images/mstile-150x150.png" />
<meta name="msapplication-wide310x150logo" content="/images/mstile-310x150.png" />
<meta name="msapplication-square310x310logo" content="/images/mstile-310x310.png" />
</head>

<body class="post">

<!--[if lt IE 9]><div class="browser-upgrade alert alert-info">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</div><![endif]-->

<div class="navigation-wrapper">
	<div class="site-name">
	</div><!-- /.site-name -->
	<div class="top-navigation">
		<nav role="navigation" id="site-nav" class="nav">
			<ul>
				
					<li><a href="https://ognjen.io/" 
						
						>/home</a></li>
				
					<li><a href="https://ognjen.io/posts/" 
						
						>/posts</a></li>
				
					<li><a href="https://ognjen.io/projects/" 
						
						>/projects</a></li>
				
					<li><a href="https://ognjen.io/about/" 
						
						>/about</a></li>
				
					<li><a href="https://ognjen.io/non/" 
						title="Non-business/tech etc" 
						>/non</a></li>
				
		    </ul>
		</nav>
	</div><!-- /.top-navigation -->
</div><!-- /.navigation-wrapper -->

<div id="main" role="main">
  <div class="article-author-side">
    <img  src="https://ognjen.io/images/profile.jpg" class="bio-photo" alt="Ognjen Regoje bio photo" width='100' height='100' />
<h3>
  <small class="text-muted">MY NAME IS</small><br>
  Ognjen Regoje
  <br>
  <small class="text-muted">BUT YOU CAN CALL ME OGGY</small>
</h3>
<br>
<p>
  I make things that run on the web (mostly).<br/>
  More <a href="/about">/ABOUT</a> me.
</p>

<a href="mailto:me@ognjen.io" rel="noopener" class="author-social" target="_blank">me@ognjen.io</a>
<a href="http://twitter.com/ognjenio" rel="noopener" class="author-social" target="_blank"><i class="icon-twitter"></i> Twitter</a>

<a href="https://my.linkedin.com/in/ognjenregoje" class="author-social" rel="noopener" target="_blank"><i class="icon-linkedin"></i> LinkedIn</a>
<a href="http://instagram.com/ognjenio" rel="noopener" class="author-social" target="_blank"><i class="icon-instagram"></i> Instagram</a>
<a href="http://github.com/ognjenio" class="author-social" rel="noopener" target="_blank"><i class="icon-github"></i> Github</a>


  </div>
  <article>
    <div class="headline-wrap">
      
        <img src="/images/image-previews.png" class="lead-photo">
      
      <h1>Generating more interesting image previews using imagemagick</h1>
      <h2></h2>
    </div><!--/ .headline-wrap -->
    <div class="article-wrap">
      <p>I was recently talking to a client who wanted to sell digital images. In the gallery the free ones would be shown but the ones for sale would be blurred out entirely.</p>

<p>Even though I ended up not doing the project I was curious about how to generate image previews that are better then just blurring the entire image. After all, users would need to get a sense of what it looks like before they’d want to buy it.</p>

<p>The two most common solutions are to show a version with poor resolution or to overlay a watermark on it. Both are easy to implement and work fairly well.</p>

<p>I wanted to see if there was a way to selectively hide parts of a higher resolution image while hiding it more than a watermark.</p>

<p>I wanted the end-result to be a teaser image of sorts. The user should “see” what it is. It should look interesting. But it shouldn’t be usable. The lead image about shows the end result that I’m quite happy with. Below is the process I went through to achieve it.</p>

<p>I mostly used <code class="language-plaintext highlighter-rouge">mini_magick</code> in order to replicate how a web application might execute these transformations. But running the commands directly is entirely doable and in fact I do so in a couple of places. <code class="language-plaintext highlighter-rouge">mini_magick</code> after all is just a wrapper around that helps to build the commands.</p>

<h2 id="blurring-the-image-as-a-control">Blurring the image as a control</h2>

<p>imagemagick has three ways of blurring. The normal <code class="language-plaintext highlighter-rouge">blur</code>, <code class="language-plaintext highlighter-rouge">gaussian-blur</code> and <code class="language-plaintext highlighter-rouge">adaptive-blur</code>.</p>

<div class="language-ruby highlighter-rouge"><div class="highlight"><pre class="highlight"><code><span class="nb">require</span> <span class="s1">'mini_magick'</span>

<span class="no">INPUT_FILE</span> <span class="o">=</span> <span class="s2">"image-previews-input-1.jpg"</span>

<span class="n">convert</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Tool</span><span class="o">::</span><span class="no">Convert</span><span class="p">.</span><span class="nf">new</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="no">INPUT_FILE</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">blur</span><span class="p">(</span><span class="s2">"0x100"</span><span class="p">)</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="s2">"plain-blur-output.jpg"</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">call</span>

<span class="n">convert</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Tool</span><span class="o">::</span><span class="no">Convert</span><span class="p">.</span><span class="nf">new</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="no">INPUT_FILE</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">gaussian_blur</span><span class="p">(</span><span class="s2">"0x100"</span><span class="p">)</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="s2">"gaussian-blur-output.jpg"</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">call</span>
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>Blur</th>
      <th>Gaussian</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/image-previews-input-1.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-plain-blur-output.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-gaussian-blur-output.jpg" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>The regular blur and the gaussian looked nearly the same. The regular blur ran much quicker.</p>

<h2 id="blurring-only-the-center-of-the-image">Blurring only the center of the image</h2>

<p>The documentation for adaptive blur sounded like it was exactly what I had in mind: it blurs less towards the edges of the image.</p>

<div class="language-ruby highlighter-rouge"><div class="highlight"><pre class="highlight"><code><span class="nb">require</span> <span class="s1">'mini_magick'</span>

<span class="no">INPUT_FILE</span> <span class="o">=</span> <span class="s2">"image-previews-input-1.jpg"</span>

<span class="n">convert</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Tool</span><span class="o">::</span><span class="no">Convert</span><span class="p">.</span><span class="nf">new</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="no">INPUT_FILE</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">adaptive_blur</span><span class="p">(</span><span class="s2">"0x100"</span><span class="p">)</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="s2">"adaptive-blur-output.jpg"</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">call</span>
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Blur</th>
      <th>Adaptive</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/image-previews-plain-blur-output.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-adaptive-blur-output.jpg" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>However, upon closer reading I understood that it blurs the edges <em>in the image</em> less.</p>

<blockquote>
  <p>Blur images, except close to the edges as defined by an edge detection
    on the image.  Eg make the colors smoother, but don’t destroy any
    sharp edges the image may have.</p>
</blockquote>

<p><small>From: <a href="https://imagemagick.org/script/command-line-options.php#adaptive-blur">https://imagemagick.org/script/command-line-options.php#adaptive-blur</a></small></p>

<p>Blurring the center more can be accomplished by generating a circular gradient to serve as a map for the blur.</p>

<div class="language-sh highlighter-rouge"><div class="highlight"><pre class="highlight"><code>convert <span class="nt">-size</span> 500x750 radial-gradient:white-black image-previews-circle-map.png

convert image-previews-input-1.jpg image-previews-circle-map.png <span class="se">\</span>
  <span class="nt">-compose</span> blur <span class="nt">-set</span> option:compose:args 10x20 <span class="nt">-composite</span> <span class="se">\</span>
  image-previews-circle-map-blur-output.png
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>Composite blur</th>
      <th>Regular Blur</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/image-previews-input-1.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-circle-map-blur-output.png" alt="Input images" /></td>
      <td><img src="/images/image-previews-plain-blur-output.jpg" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>That already looks better then just blurring the entire image. It’s however still quite revealing.</p>

<h2 id="cover-the-image-in-black-triangles">Cover the image in black triangles</h2>

<p>Next, I wanted to try to cover the image in black triangles.</p>

<div class="language-ruby highlighter-rouge"><div class="highlight"><pre class="highlight"><code><span class="nb">require</span> <span class="s1">'mini_magick'</span>
<span class="no">INPUT_FILE</span> <span class="o">=</span> <span class="s2">"image-previews-input-1.jpg"</span>
<span class="n">image</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="no">INPUT_FILE</span><span class="p">)</span>
<span class="n">size</span> <span class="o">=</span> <span class="n">image</span><span class="p">.</span><span class="nf">dimensions</span><span class="p">.</span><span class="nf">map</span><span class="p">{</span><span class="o">|</span><span class="n">x</span><span class="o">|</span> <span class="n">x</span><span class="p">}</span>
<span class="n">width</span> <span class="o">=</span> <span class="n">size</span><span class="p">[</span><span class="mi">0</span><span class="p">]</span>
<span class="n">height</span> <span class="o">=</span> <span class="n">size</span><span class="p">[</span><span class="mi">1</span><span class="p">]</span>

<span class="n">density</span> <span class="o">=</span> <span class="mi">40</span> <span class="c1"># to control the size of the triangles</span>

<span class="n">sh</span> <span class="o">=</span> <span class="n">height</span> <span class="o">/</span> <span class="n">density</span>
<span class="n">sw</span> <span class="o">=</span> <span class="n">width</span> <span class="o">/</span> <span class="n">density</span>

<span class="n">convert</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Tool</span><span class="o">::</span><span class="no">Convert</span><span class="p">.</span><span class="nf">new</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="no">INPUT_FILE</span>

<span class="n">density</span><span class="p">.</span><span class="nf">times</span> <span class="k">do</span> <span class="o">|</span><span class="n">w</span><span class="o">|</span>
  <span class="n">density</span><span class="p">.</span><span class="nf">times</span> <span class="k">do</span> <span class="o">|</span><span class="n">h</span><span class="o">|</span>
    <span class="n">convert</span><span class="p">.</span><span class="nf">draw</span><span class="p">(</span><span class="s2">"polygon </span><span class="si">#{</span><span class="n">sw</span> <span class="o">*</span> <span class="n">w</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sh</span> <span class="o">*</span> <span class="n">h</span><span class="si">}</span><span class="s2"> </span><span class="si">#{</span><span class="n">sw</span> <span class="o">*</span> <span class="p">(</span><span class="n">w</span><span class="o">+</span><span class="mi">1</span><span class="p">)</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sh</span> <span class="o">*</span> <span class="n">h</span><span class="si">}</span><span class="s2"> </span><span class="si">#{</span><span class="n">sw</span> <span class="o">*</span> <span class="p">(</span><span class="n">w</span><span class="o">+</span><span class="mi">1</span><span class="p">)</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sh</span> <span class="o">*</span> <span class="p">(</span><span class="n">h</span> <span class="o">+</span> <span class="mi">1</span><span class="p">)</span><span class="si">}</span><span class="s2">"</span><span class="p">)</span>
  <span class="k">end</span>
<span class="k">end</span>

<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="s2">"output-with-triangles.png"</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">call</span>
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>With Triangles</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/image-previews-input-1.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-output-with-triangles.png" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>This looks quite good. The image isn’t really usable for anything but at the same time users can quite clearly “see” what the image is about.</p>

<p>The script above doesn’t take into account the spacing left over on the right and bottom due to integer division, but that’d be trivial to fix.</p>

<h3 id="increase-probability-of-triangles-towards-the-center">Increase probability of triangles towards the center</h3>

<p>Next, I wanted to see if the results would be better if there were fewer triangles generated near the edges of the image.</p>

<div class="language-ruby highlighter-rouge"><div class="highlight"><pre class="highlight"><code><span class="nb">require</span> <span class="s1">'mini_magick'</span>
<span class="no">INPUT_FILE</span> <span class="o">=</span> <span class="s2">"image-previews-input-1.jpg"</span>
<span class="n">image</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="no">INPUT_FILE</span><span class="p">)</span>
<span class="n">size</span> <span class="o">=</span> <span class="n">image</span><span class="p">.</span><span class="nf">dimensions</span><span class="p">.</span><span class="nf">map</span><span class="p">{</span><span class="o">|</span><span class="n">x</span><span class="o">|</span> <span class="n">x</span><span class="p">}</span>
<span class="n">width</span> <span class="o">=</span> <span class="n">size</span><span class="p">[</span><span class="mi">0</span><span class="p">]</span>
<span class="n">height</span> <span class="o">=</span> <span class="n">size</span><span class="p">[</span><span class="mi">1</span><span class="p">]</span>

<span class="n">density</span> <span class="o">=</span> <span class="mi">40</span>

<span class="n">sh</span> <span class="o">=</span> <span class="n">height</span> <span class="o">/</span> <span class="n">density</span>
<span class="n">sw</span> <span class="o">=</span> <span class="n">width</span> <span class="o">/</span> <span class="n">density</span>

<span class="n">hh</span> <span class="o">=</span> <span class="n">height</span> <span class="o">/</span> <span class="mi">2</span>
<span class="n">hw</span> <span class="o">=</span> <span class="n">width</span> <span class="o">/</span> <span class="mi">2</span>

<span class="n">convert</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Tool</span><span class="o">::</span><span class="no">Convert</span><span class="p">.</span><span class="nf">new</span>
<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="no">INPUT_FILE</span>

<span class="n">density</span><span class="p">.</span><span class="nf">times</span> <span class="k">do</span> <span class="o">|</span><span class="n">w</span><span class="o">|</span>
  <span class="n">density</span><span class="p">.</span><span class="nf">times</span> <span class="k">do</span> <span class="o">|</span><span class="n">h</span><span class="o">|</span>
    <span class="n">c</span> <span class="o">=</span> <span class="nb">rand</span>
    <span class="n">prob</span> <span class="o">=</span> <span class="mi">1</span> <span class="o">-</span> <span class="p">((((</span><span class="n">hw</span><span class="p">.</span><span class="nf">to_f</span> <span class="o">-</span> <span class="p">(</span><span class="n">w</span><span class="o">*</span><span class="n">sw</span><span class="p">).</span><span class="nf">to_f</span><span class="p">).</span><span class="nf">abs</span> <span class="o">/</span> <span class="n">hw</span><span class="p">.</span><span class="nf">to_f</span><span class="p">)</span> <span class="o">+</span> <span class="p">(</span><span class="n">hh</span><span class="p">.</span><span class="nf">to_f</span> <span class="o">-</span> <span class="p">(</span><span class="n">h</span><span class="o">*</span><span class="n">sh</span><span class="p">).</span><span class="nf">to_f</span><span class="p">).</span><span class="nf">abs</span> <span class="o">/</span> <span class="n">hh</span><span class="p">.</span><span class="nf">to_f</span><span class="p">)</span> <span class="o">/</span> <span class="mi">2</span><span class="p">)</span> <span class="o">+</span> <span class="mf">0.1</span>
    <span class="k">if</span> <span class="n">c</span> <span class="o">&lt;</span> <span class="n">prob</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">draw</span><span class="p">(</span><span class="s2">"polygon </span><span class="si">#{</span><span class="n">sw</span> <span class="o">*</span> <span class="n">w</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sh</span> <span class="o">*</span> <span class="n">h</span><span class="si">}</span><span class="s2"> </span><span class="si">#{</span><span class="n">sw</span> <span class="o">*</span> <span class="p">(</span><span class="n">w</span><span class="o">+</span><span class="mi">1</span><span class="p">)</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sh</span> <span class="o">*</span> <span class="n">h</span><span class="si">}</span><span class="s2"> </span><span class="si">#{</span><span class="n">sw</span> <span class="o">*</span> <span class="p">(</span><span class="n">w</span><span class="o">+</span><span class="mi">1</span><span class="p">)</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sh</span> <span class="o">*</span> <span class="p">(</span><span class="n">h</span> <span class="o">+</span> <span class="mi">1</span><span class="p">)</span><span class="si">}</span><span class="s2">"</span><span class="p">)</span>
    <span class="k">end</span>
  <span class="k">end</span>
<span class="k">end</span>

<span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="s2">"image-previews-output-with-probability-triangles.png"</span>
<span class="n">convert</span><span class="p">.</span><span class="nf">call</span>
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>With probabilistic triangles</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/image-previews-input-1.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-output-with-probability-triangles.png" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>Slightly more interesting. Not a big improvement on just covering the entire image however.</p>

<h3 id="make-the-triangles-transparent">Make the triangles transparent</h3>

<p>Then I tried blurring the triangles instead of just filling them in.</p>

<p>For this example I had to use a larger input image. With a smaller image the transparency wouldn’t be applied as well and there would be tearing when they triangles are composed back.</p>

<p>I also reduced the density and the blur since it was taking a long time to run.</p>

<p>Since the density was reduced I changed the triangles to polygons in order to blur a larger part of the image.</p>

<div class="language-ruby highlighter-rouge"><div class="highlight"><pre class="highlight"><code><span class="nb">require</span> <span class="s1">'mini_magick'</span>

<span class="no">INPUT_FILE</span> <span class="o">=</span> <span class="s2">"input-1-lg.jpg"</span>

<span class="n">image</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="no">INPUT_FILE</span><span class="p">)</span>
<span class="n">size</span> <span class="o">=</span> <span class="n">image</span><span class="p">.</span><span class="nf">dimensions</span><span class="p">.</span><span class="nf">map</span><span class="p">{</span><span class="o">|</span><span class="n">x</span><span class="o">|</span> <span class="n">x</span><span class="p">}</span>
<span class="n">height</span> <span class="o">=</span> <span class="n">size</span><span class="p">[</span><span class="mi">0</span><span class="p">]</span>
<span class="n">width</span> <span class="o">=</span> <span class="n">size</span><span class="p">[</span><span class="mi">1</span><span class="p">]</span>

<span class="n">density</span> <span class="o">=</span> <span class="mi">10</span>

<span class="n">sh</span> <span class="o">=</span> <span class="n">height</span> <span class="o">/</span> <span class="n">density</span>
<span class="n">sw</span> <span class="o">=</span> <span class="n">width</span> <span class="o">/</span> <span class="n">density</span>

<span class="n">fragments</span> <span class="o">=</span> <span class="p">[]</span>

<span class="n">hh</span> <span class="o">=</span> <span class="n">height</span> <span class="o">/</span> <span class="mi">2</span>
<span class="n">hw</span> <span class="o">=</span> <span class="n">width</span> <span class="o">/</span> <span class="mi">2</span>

<span class="n">density</span><span class="p">.</span><span class="nf">times</span> <span class="k">do</span> <span class="o">|</span><span class="n">w</span><span class="o">|</span>
  <span class="n">density</span><span class="p">.</span><span class="nf">times</span> <span class="k">do</span> <span class="o">|</span><span class="n">h</span><span class="o">|</span>
    <span class="n">c</span> <span class="o">=</span> <span class="nb">rand</span>
    <span class="n">prob</span> <span class="o">=</span> <span class="mi">1</span> <span class="o">-</span> <span class="p">((((</span><span class="n">hw</span><span class="p">.</span><span class="nf">to_f</span> <span class="o">-</span> <span class="p">(</span><span class="n">w</span><span class="o">*</span><span class="n">sw</span><span class="p">).</span><span class="nf">to_f</span><span class="p">).</span><span class="nf">abs</span> <span class="o">/</span> <span class="n">hw</span><span class="p">.</span><span class="nf">to_f</span><span class="p">)</span> <span class="o">+</span> <span class="p">(</span><span class="n">hh</span><span class="p">.</span><span class="nf">to_f</span> <span class="o">-</span> <span class="p">(</span><span class="n">h</span><span class="o">*</span><span class="n">sh</span><span class="p">).</span><span class="nf">to_f</span><span class="p">).</span><span class="nf">abs</span> <span class="o">/</span> <span class="n">hh</span><span class="p">.</span><span class="nf">to_f</span><span class="p">)</span> <span class="o">/</span> <span class="mi">2</span><span class="p">)</span>
    <span class="k">if</span> <span class="n">c</span> <span class="o">&lt;</span> <span class="n">prob</span>
      <span class="n">fragments</span><span class="p">.</span><span class="nf">push</span><span class="p">({</span><span class="ss">w: </span><span class="n">w</span><span class="o">*</span><span class="n">sw</span><span class="p">,</span> <span class="ss">h: </span><span class="n">h</span><span class="o">*</span><span class="n">sh</span><span class="p">})</span>

      <span class="n">convert</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Tool</span><span class="o">::</span><span class="no">Convert</span><span class="p">.</span><span class="nf">new</span>
      <span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="no">INPUT_FILE</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">crop</span><span class="p">(</span><span class="s2">"</span><span class="si">#{</span><span class="n">sh</span><span class="si">}</span><span class="s2">x</span><span class="si">#{</span><span class="n">sw</span><span class="si">}</span><span class="s2">+</span><span class="si">#{</span><span class="n">h</span><span class="o">*</span><span class="n">sh</span><span class="si">}</span><span class="s2">+</span><span class="si">#{</span><span class="n">w</span><span class="o">*</span><span class="n">sw</span><span class="si">}</span><span class="s2">"</span><span class="p">)</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">blur</span><span class="p">(</span><span class="s2">"0x200"</span><span class="p">)</span>


      <span class="n">convert</span><span class="p">.</span><span class="nf">fill</span><span class="p">(</span><span class="s2">"black"</span><span class="p">)</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">draw</span><span class="p">(</span><span class="s2">"polygon </span><span class="si">#{</span><span class="n">sh</span><span class="o">/</span><span class="mi">2</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sw</span><span class="si">}</span><span class="s2"> </span><span class="si">#{</span><span class="n">sh</span><span class="si">}</span><span class="s2">,</span><span class="si">#{</span><span class="n">sw</span><span class="si">}</span><span class="s2"> </span><span class="si">#{</span><span class="n">sh</span><span class="si">}</span><span class="s2">,0"</span><span class="p">)</span> <span class="c1"># Use sh/2 instead of just sh so that the "triangle" starts in the middle rather then in the corner to cover more of the image</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">fuzz</span><span class="p">(</span><span class="s2">"15%"</span><span class="p">)</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">define</span><span class="p">(</span><span class="s1">'png:color-type=6'</span><span class="p">)</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">transparent</span><span class="p">(</span><span class="s2">"black"</span><span class="p">)</span>

      <span class="n">convert</span> <span class="o">&lt;&lt;</span> <span class="s2">"output-crop-with-triangle-</span><span class="si">#{</span><span class="n">w</span><span class="o">*</span><span class="n">sw</span><span class="si">}</span><span class="s2">-</span><span class="si">#{</span><span class="n">h</span><span class="o">*</span><span class="n">sh</span><span class="si">}</span><span class="s2">.png"</span>
      <span class="n">convert</span><span class="p">.</span><span class="nf">call</span>

    <span class="k">end</span>
  <span class="k">end</span>
<span class="k">end</span>

<span class="n">image</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="no">INPUT_FILE</span><span class="p">)</span>
<span class="n">fragments</span><span class="p">.</span><span class="nf">each</span> <span class="k">do</span> <span class="o">|</span><span class="n">x</span><span class="o">|</span>
  <span class="n">cropped</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">new</span><span class="p">(</span><span class="s2">"output-crop-with-triangle-</span><span class="si">#{</span><span class="n">x</span><span class="p">[</span><span class="ss">:w</span><span class="p">]</span><span class="si">}</span><span class="s2">-</span><span class="si">#{</span><span class="n">x</span><span class="p">[</span><span class="ss">:h</span><span class="p">]</span><span class="si">}</span><span class="s2">.png"</span><span class="p">)</span>
  <span class="n">result</span> <span class="o">=</span> <span class="n">image</span><span class="p">.</span><span class="nf">composite</span><span class="p">(</span><span class="n">cropped</span><span class="p">)</span> <span class="k">do</span> <span class="o">|</span><span class="n">c</span><span class="o">|</span>
    <span class="n">c</span><span class="p">.</span><span class="nf">compose</span> <span class="s2">"Over"</span>
    <span class="n">c</span><span class="p">.</span><span class="nf">geometry</span> <span class="s2">"+</span><span class="si">#{</span><span class="n">x</span><span class="p">[</span><span class="ss">:h</span><span class="p">]</span><span class="si">}</span><span class="s2">+</span><span class="si">#{</span><span class="n">x</span><span class="p">[</span><span class="ss">:w</span><span class="p">]</span><span class="si">}</span><span class="s2">"</span>
  <span class="k">end</span>
  <span class="n">result</span><span class="p">.</span><span class="nf">write</span> <span class="s2">"image-previews-output-with-probability-transparent-triangles.jpg"</span>
  <span class="no">File</span><span class="p">.</span><span class="nf">delete</span><span class="p">(</span><span class="s2">"output-crop-with-triangle-</span><span class="si">#{</span><span class="n">x</span><span class="p">[</span><span class="ss">:w</span><span class="p">]</span><span class="si">}</span><span class="s2">-</span><span class="si">#{</span><span class="n">x</span><span class="p">[</span><span class="ss">:h</span><span class="p">]</span><span class="si">}</span><span class="s2">.png"</span><span class="p">)</span>
  <span class="k">if</span> <span class="n">fragments</span><span class="p">.</span><span class="nf">last</span> <span class="o">!=</span> <span class="n">x</span>
    <span class="n">image</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="s2">"image-previews-output-with-probability-transparent-triangles.jpg"</span><span class="p">)</span>
  <span class="k">end</span>
<span class="k">end</span>
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>With probabilistic transparent polygons</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/input-1-lg.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-transparent-triangles.jpg" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>I think this looks quite good and is what I imagined.</p>

<h2 id="applying-a-ripple-effect">Applying a ripple effect</h2>

<p>In the <code class="language-plaintext highlighter-rouge">imagemagick</code> docs I found an example for composing an image with a ripple effect so ended up trying that as well.</p>

<p>First, a ripple mask is created:</p>

<div class="language-sh highlighter-rouge"><div class="highlight"><pre class="highlight"><code>convert <span class="nt">-size</span> 667x1000 gradient:  <span class="nt">-evaluate</span> sin 60  image-previews-wave-gradient.jpg
</code></pre></div></div>

<p><img src="/images/image-previews-wave-gradient.jpg" alt="Input images" /></p>

<p>The <code class="language-plaintext highlighter-rouge">667x1000</code> should correspond to the <code class="language-plaintext highlighter-rouge">widthxheight</code> of the image.</p>

<p>The mask is then used to displace the pixels of the original image.</p>

<div class="language-ruby highlighter-rouge"><div class="highlight"><pre class="highlight"><code><span class="no">INPUT_FILE</span> <span class="o">=</span> <span class="s2">"image-previews-input-1.jpg"</span>
<span class="n">gradient</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="s2">"image-previews-wave-gradient.jpg"</span><span class="p">)</span>
<span class="n">image</span> <span class="o">=</span> <span class="no">MiniMagick</span><span class="o">::</span><span class="no">Image</span><span class="p">.</span><span class="nf">open</span><span class="p">(</span><span class="no">INPUT_FILE</span><span class="p">)</span>
<span class="n">result</span> <span class="o">=</span> <span class="n">image</span><span class="p">.</span><span class="nf">composite</span><span class="p">(</span><span class="n">gradient</span><span class="p">)</span> <span class="k">do</span> <span class="o">|</span><span class="n">c</span><span class="o">|</span>
  <span class="n">c</span><span class="p">.</span><span class="nf">displace</span><span class="p">(</span><span class="s2">"5x20"</span><span class="p">)</span>
<span class="k">end</span>
<span class="n">result</span><span class="p">.</span><span class="nf">write</span> <span class="s2">"image-previews-rippled-output.jpg"</span>
</code></pre></div></div>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>Rippled</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/image-previews-input-1.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-rippled-output.jpg" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

<p>This also looks like an interesting result that might be useful but I think it obfuscates too much of the image.</p>

<h2 id="conclusion">Conclusion</h2>

<p>I think blurring random polygons near the center of the image creates a more interesting image preview then just blurring the entire image, showing a low resolution or applying a watermark.</p>

<table>
  <thead>
    <tr>
      <th>Original</th>
      <th>Blur</th>
      <th>With probabilistic transparent polygons</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td><img src="/images/input-1-lg.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-plain-blur-lg-output.jpg" alt="Input images" /></td>
      <td><img src="/images/image-previews-transparent-triangles.jpg" alt="Input images" /></td>
    </tr>
  </tbody>
</table>

      
        <p class="no-margins"><small>
          
          
            <a href="https://ognjen.io/categories/imagemagick/index.html">#imagemagick</a>
          
            <a href="https://ognjen.io/categories/mini-magick/index.html">#mini_magick</a>
          
            <a href="https://ognjen.io/categories/technical/index.html">#technical</a>
          
        </small></p>
      
      <hr>
      <div class="feedback">
        <strong>
          <a href="mailto:me@ognjen.io">Have a thought about this? I'd love to hear it: me@ognjen.io</a>
          <br>
          <small>
            <a href="mailto:me@ognjen.io?subject=Feedback%20about%20&quot;Generating more interesting image previews using imagemagick&quot;&body=Could%20you%20score%20this%20from%201-10%20on%20how%20satisfied%20you%20were%20after%20reading%20it%3F%0D%0A%0D%0ADon%E2%80%99t%20be%20afraid%20to%20give%20me%20a%20low%20score.%20The%20more%20people%20tell%20me%20this%20isn't%20good%20yet%2C%20the%20more%20I'm%20motivated%20to%20make%20it%20even%20better.%0D%0A%0D%0AAlso%2C%20feel%20free%20to%20point%20out%20any%20problems%20and%20to%20suggest%20ideal%20fixes%3A%0D%0A%0D%0ALogic**%20%E2%80%94%20What%20didn%E2%80%99t%20you%20agree%20with%3F%0D%0AClarity%20%E2%80%94%20What%20was%20unclear%3F%0D%0AInterest%20%E2%80%94%20What%20bored%20you%3F%0D%0ABrevity%20%E2%80%94%20What%20unnecessary%20things%20should%20be%20removed%3F%0D%0AExpansion%20%E2%80%94%20What%20unanswered%20questions%20were%20you%20left%20with%3F">
              Or send me feedback. It will take less than 20 seconds.
            </a>
          </small>
        </strong>
      </div>
      
      
        <hr>
        <div class="sources">
          <h4>Sources</h4>
          <ul>
            
              <li>
                <a href="https://github.com/minimagick/minimagick#composite" target="_blank" rel="noopener">https://github.com/minimagick/minimagick#composite</a>
              </li>
            
              <li>
                <a href="https://stackoverflow.com/questions/8894194/retrieving-the-hex-code-of-the-color-of-a-given-pixel>" target="_blank" rel="noopener">https://stackoverflow.com/questions/8894194/retrieving-the-hex-code-of-the-color-of-a-given-pixel></a>
              </li>
            
              <li>
                <a href="https://www.imagemagick.org/script/command-line-options.php#draw" target="_blank" rel="noopener">https://www.imagemagick.org/script/command-line-options.php#draw</a>
              </li>
            
              <li>
                <a href="https://legacy.imagemagick.org/Usage/crop/" target="_blank" rel="noopener">https://legacy.imagemagick.org/Usage/crop/</a>
              </li>
            
              <li>
                <a href="https://imagemagick.org/script/command-line-options.php#adaptive-blur" target="_blank" rel="noopener">https://imagemagick.org/script/command-line-options.php#adaptive-blur</a>
              </li>
            
              <li>
                <a href="https://legacy.imagemagick.org/Usage/draw/#circles" target="_blank" rel="noopener">https://legacy.imagemagick.org/Usage/draw/#circles</a>
              </li>
            
              <li>
                <a href="https://legacy.imagemagick.org/Usage/crop/" target="_blank" rel="noopener">https://legacy.imagemagick.org/Usage/crop/</a>
              </li>
            
              <li>
                <a href="https://legacy.imagemagick.org/Usage/blur/#blur_channel" target="_blank" rel="noopener">https://legacy.imagemagick.org/Usage/blur/#blur_channel</a>
              </li>
            
              <li>
                <a href="https://im.snibgo.com/selblur.htm" target="_blank" rel="noopener">https://im.snibgo.com/selblur.htm</a>
              </li>
            
          </ul>
        </div>
      
      <hr>
      <div class="navigation">
        
          <a class="prev" href="/front-matter-editor/">&laquo; Introducing the Front Matter Editor</a>
        
        
          <a class="next" href="/turns-out-elastic-arent-the-bad-guys/">Turns out Elastic aren't the bad guys &raquo;</a>
        
      </div>
      <div class="clearfix"></div>
    </div>
    <div>
      <footer role="contentinfo">
        <div class="article-author-bottom">
          <hr>
          <img  src="https://ognjen.io/images/profile.jpg" class="bio-photo" alt="Ognjen Regoje bio photo" width='100' height='100' />
<h3>
  <small class="text-muted">MY NAME IS</small><br>
  Ognjen Regoje
  <br>
  <small class="text-muted">BUT YOU CAN CALL ME OGGY</small>
</h3>
<br>
<p>
  I make things that run on the web (mostly).<br/>
  More <a href="/about">/ABOUT</a> me.
</p>

<a href="mailto:me@ognjen.io" rel="noopener" class="author-social" target="_blank">me@ognjen.io</a>
<a href="http://twitter.com/ognjenio" rel="noopener" class="author-social" target="_blank"><i class="icon-twitter"></i> Twitter</a>

<a href="https://my.linkedin.com/in/ognjenregoje" class="author-social" rel="noopener" target="_blank"><i class="icon-linkedin"></i> LinkedIn</a>
<a href="http://instagram.com/ognjenio" rel="noopener" class="author-social" target="_blank"><i class="icon-instagram"></i> Instagram</a>
<a href="http://github.com/ognjenio" class="author-social" rel="noopener" target="_blank"><i class="icon-github"></i> Github</a>


        </div>
        <br>
        <p class="byline"><strong>Generating more interesting image previews using imagemagick</strong> was published on <time datetime="2021-04-10T00:00:00+08:00">April 10, 2021</time> by <a href="https://ognjen.io/about" title="About Ognjen Regoje">Ognjen Regoje</a>.</p>
      </footer>
    </div><!-- /.article-wrap -->
  </article>
</div><!-- /#main -->

<div class="footer-wrap">
  
  <footer>
    <small>&copy; 2021 Ognjen Regoje. me@ognjen.io</small>

  </footer>
</div><!-- /.footer-wrap -->

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>
<script>window.jQuery || document.write('<script src="https://ognjen.io/assets/js/vendor/jquery-1.9.1.min.js"><\/script>')</script>
<script src="https://ognjen.io/assets/js/scripts.min.js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-61545683-1', 'auto');
  ga('send', 'pageview');
</script>


</body>
</html>